import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*\\*![^*]*\\*+(?:[^\\/*][^*]*\\*+)*\\/";
final String string = "/**!\n"
+ " * Plugin Name 1.0.0\n"
+ " * @author Name\n"
+ " */\n\n"
+ "/*! Test */\n\n"
+ "/* Test */\n\n"
+ "/************************************************************************/\n"
+ "/******/ /* Test */\n"
+ "/******/\n"
+ "/*!*********************!*\\\n"
+ " !*** ./index.ts ***!\n"
+ " \\*********************/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}