using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?<tagnames> @CUSTOM-AT-1 | @CUSTOM-AT-2)
(?<number> -? (?= [1-9]|0(?!\d) ) \d+ (\.\d+)? ([eE] [+-]? \d+)? )
(?<boolean> true | false | null )
(?<string> \"" ([^\""\\\\]* | \\\\ [\""\\\\bfnrt\/] | \\\\ u [0-9a-f]{4} )* \"" )
(?<array> \[ (?: (?&json) (?: , (?&json) )* )? \s* \] )
(?<pair> \s* (?&string) \s* : (?&json) )
(?<object> \{ (?: (?&pair) (?: , (?&pair) )* )? \s* \} )
(?<fieldname> [a-zA-Z0-9\_\-]+ )
(?<json> \s* (?: (?&number) | (?&boolean) | (?&string) | (?&array) | (?&object) ) )
(?<fieldlist> (?: (?&fieldname) (?: , (?&fieldname) )+ )+ ) )
(?<actiontag> (?&tagnames)
)
(?:\=
(?'params'
(?:
(?'match_list'(?&fieldlist))
|
(?'match_json'(?&json))
|
(?'match_string'(?:[[:alnum:]\_\-]+))
)
)
)";
string input = @"@FIELDLIST=field_1,field_2
@STRING=""Bar""
@JSON={""foo"":""bar""}
@CUSTOM-AT-2={""strict"":true, ""targets"":[""field_3"", ""field_7""], ""title"":""Custom Title"", ""message"":""This is a custom message""}
@CUSTOM-AT-1={""strict"":true, ""targets"":[""field_3"", ""field_7""], ""title"":""Custom Title"", ""message"":""This is a custom message""}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}