import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<tagnames> @CUSTOM-AT-1 | @CUSTOM-AT-2)\n"
+ " (?<number> -? (?= [1-9]|0(?!\\d) ) \\d+ (\\.\\d+)? ([eE] [+-]? \\d+)? )\n"
+ " (?<boolean> true | false | null )\n"
+ " (?<string> \\\" ([^\\\"\\\\\\\\]* | \\\\\\\\ [\\\"\\\\\\\\bfnrt\\/] | \\\\\\\\ u [0-9a-f]{4} )* \\\" )\n"
+ " (?<array> \\[ (?: (?&json) (?: , (?&json) )* )? \\s* \\] )\n"
+ " (?<pair> \\s* (?&string) \\s* : (?&json) )\n"
+ " (?<object> \\{ (?: (?&pair) (?: , (?&pair) )* )? \\s* \\} )\n"
+ " (?<fieldname> [a-zA-Z0-9\\_\\-]+ )\n"
+ " (?<json> \\s* (?: (?&number) | (?&boolean) | (?&string) | (?&array) | (?&object) ) )\n"
+ " (?<fieldlist> (?: (?&fieldname) (?: , (?&fieldname) )+ )+ ) )\n"
+ " (?<actiontag> (?&tagnames)\n"
+ ")\n"
+ "(?:\\=\n"
+ " (?'params'\n"
+ " (?:\n"
+ " (?'match_list'(?&fieldlist))\n"
+ " |\n"
+ " (?'match_json'(?&json))\n"
+ " |\n"
+ " (?'match_string'(?:[[:alnum:]\\_\\-]+))\n"
+ " )\n"
+ " )\n"
+ ")";
final String string = "@FIELDLIST=field_1,field_2\n\n\n"
+ "@STRING=\"Bar\"\n\n\n"
+ "@JSON={\"foo\":\"bar\"}\n\n\n"
+ "@CUSTOM-AT-2={\"strict\":true, \"targets\":[\"field_3\", \"field_7\"], \"title\":\"Custom Title\", \"message\":\"This is a custom message\"}\n\n"
+ "@CUSTOM-AT-1={\"strict\":true, \"targets\":[\"field_3\", \"field_7\"], \"title\":\"Custom Title\", \"message\":\"This is a custom message\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}