import re
regex = re.compile(r"""
(?(DEFINE)
(?<tagnames> @CUSTOM-AT-1 | @CUSTOM-AT-2)
(?<number> -? (?= [1-9]|0(?!\d) ) \d+ (\.\d+)? ([eE] [+-]? \d+)? )
(?<boolean> true | false | null )
(?<string> \" ([^\"\\\\]* | \\\\ [\"\\\\bfnrt\/] | \\\\ u [0-9a-f]{4} )* \" )
(?<array> \[ (?: (?&json) (?: , (?&json) )* )? \s* \] )
(?<pair> \s* (?&string) \s* : (?&json) )
(?<object> \{ (?: (?&pair) (?: , (?&pair) )* )? \s* \} )
(?<fieldname> [a-zA-Z0-9\_\-]+ )
(?<json> \s* (?: (?&number) | (?&boolean) | (?&string) | (?&array) | (?&object) ) )
(?<fieldlist> (?: (?&fieldname) (?: , (?&fieldname) )+ )+ ) )
(?<actiontag> (?&tagnames)
)
(?:\=
(?'params'
(?:
(?'match_list'(?&fieldlist))
|
(?'match_json'(?&json))
|
(?'match_string'(?:[[:alnum:]\_\-]+))
)
)
)
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = ("@FIELDLIST=field_1,field_2\n\n\n"
"@STRING=\"Bar\"\n\n\n"
"@JSON={\"foo\":\"bar\"}\n\n\n"
"@CUSTOM-AT-2={\"strict\":true, \"targets\":[\"field_3\", \"field_7\"], \"title\":\"Custom Title\", \"message\":\"This is a custom message\"}\n\n"
"@CUSTOM-AT-1={\"strict\":true, \"targets\":[\"field_3\", \"field_7\"], \"title\":\"Custom Title\", \"message\":\"This is a custom message\"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")