#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\-?\$[0-1][0-5]+(\.[0-9]{2,2})?$|^\-?\$[0-5]+(\.[0-9]{2,2})?$"
Local $sString = "$12.15" & @CRLF & _
"$5.99" & @CRLF & _
"$18.99" & @CRLF & _
"$05.5" & @CRLF & _
"$526262100.41" & @CRLF & _
"$.99"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")