re = /^\-?\$[0-1][0-5]+(\.[0-9]{2,2})?$|^\-?\$[0-5]+(\.[0-9]{2,2})?$/m
str = '$12.15
$5.99
$18.99
$05.5
$526262100.41
$.99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end