import re
regex = re.compile(r"^\-?\$[0-1][0-5]+(\.[0-9]{2,2})?$|^\-?\$[0-5]+(\.[0-9]{2,2})?$", flags=re.MULTILINE)
test_str = ("$12.15\n"
"$5.99\n"
"$18.99\n"
"$05.5\n"
"$526262100.41\n"
"$.99")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")