#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[zx]|ch|sh?)es$"
Local $sString = "a aases" & @CRLF & _
"aa azes" & @CRLF & _
"aa aaaaxes" & @CRLF & _
"aa a aaches" & @CRLF & _
"aaa aa aaaashes" & @CRLF & _
"and more text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")