using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[zx]|ch|sh?)es$";
string input = @"a aases
aa azes
aa aaaaxes
aa a aaches
aaa aa aaaashes
and more text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}