$re = '/(?:[zx]|ch|sh?)es$/m';
$str = 'a aases
aa azes
aa aaaaxes
aa a aaches
aaa aa aaaashes
and more text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);