const regex = /(?:[zx]|ch|sh?)es$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[zx]|ch|sh?)es$', 'gm')
const str = `a aases
aa azes
aa aaaaxes
aa a aaches
aaa aa aaaashes
and more text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}