using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:> [^:]+: |\d+=|[ ,|<>])+";
string substitution = @"\n";
string input = @"15:10:10,408 INFO <NioProcessor-11> Raw Message: 8=FIXT.1.1|9=317|35=D|49=verifix|";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}