re = /(?:> [^:]+: |\d+=|[ ,|<>])+/
str = '15:10:10,408 INFO <NioProcessor-11> Raw Message: 8=FIXT.1.1|9=317|35=D|49=verifix|'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result