const regex = /(?:> [^:]+: |\d+=|[ ,|<>])+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:> [^:]+: |\\d+=|[ ,|<>])+', 'g')
const str = `15:10:10,408 INFO <NioProcessor-11> Raw Message: 8=FIXT.1.1|9=317|35=D|49=verifix|`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);