import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+?\\\\\\K\\d+(?=_)";
final String string = "A:\\blah\\folder\\subfolders\\0126535_whatever\\file.ext\n"
+ "A:\\blah\\anotherfolder\\subfolders\\03578422_whatever\\file.ext \n"
+ "A:\\blah\\folder_with_underscore\\subfolders\\2175421_whatever\\1342121_214561_file_with_underscore.ext\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}