import Foundation
let pattern = #"^.+?\\\K\d+(?=_)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A:\blah\folder\subfolders\0126535_whatever\file.ext
A:\blah\anotherfolder\subfolders\03578422_whatever\file.ext
A:\blah\folder_with_underscore\subfolders\2175421_whatever\1342121_214561_file_with_underscore.ext
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)