const regex = /^.+?\\\K\d+(?=_)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.+?\\\\\\K\\d+(?=_)', 'gm')
const str = `A:\\blah\\folder\\subfolders\\0126535_whatever\\file.ext
A:\\blah\\anotherfolder\\subfolders\\03578422_whatever\\file.ext
A:\\blah\\folder_with_underscore\\subfolders\\2175421_whatever\\1342121_214561_file_with_underscore.ext
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}