$re = '/^.+?\\\\\K\d+(?=_)/m';
$str = 'A:\\blah\\folder\\subfolders\\0126535_whatever\\file.ext
A:\\blah\\anotherfolder\\subfolders\\03578422_whatever\\file.ext
A:\\blah\\folder_with_underscore\\subfolders\\2175421_whatever\\1342121_214561_file_with_underscore.ext
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);