import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0?[1-9]\\d*(?:\\.\\d*[0-9]*)?)|(:?^0.[1-9]+0)$";
final String string = "VALID\n"
+ "_______\n"
+ "40000\n"
+ "45\n"
+ "4\n"
+ "45.67\n"
+ "67.8\n"
+ "60.\n"
+ "61.0\n"
+ "1.00\n"
+ "01.00\n"
+ "02.00\n"
+ "03.0\n"
+ "89.50\n"
+ "50.00\n"
+ "0.10\n"
+ "0.1\n"
+ "0.2\n"
+ "0.3\n\n"
+ "NOT VALID\n"
+ "_______\n"
+ "0.00\n"
+ "00000\n"
+ "0.0\n"
+ "0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}