const regex = /^(?:0?[1-9]\d*(?:\.\d*[0-9]*)?)|(:?^0.[1-9]+0)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:0?[1-9]\\d*(?:\\.\\d*[0-9]*)?)|(:?^0.[1-9]+0)$', 'gm')
const str = `VALID
_______
40000
45
4
45.67
67.8
60.
61.0
1.00
01.00
02.00
03.0
89.50
50.00
0.10
0.1
0.2
0.3
NOT VALID
_______
0.00
00000
0.0
0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}