import re
regex = re.compile(r"^(?:0?[1-9]\d*(?:\.\d*[0-9]*)?)|(:?^0.[1-9]+0)$", flags=re.MULTILINE)
test_str = ("VALID\n"
"_______\n"
"40000\n"
"45\n"
"4\n"
"45.67\n"
"67.8\n"
"60.\n"
"61.0\n"
"1.00\n"
"01.00\n"
"02.00\n"
"03.0\n"
"89.50\n"
"50.00\n"
"0.10\n"
"0.1\n"
"0.2\n"
"0.3\n\n"
"NOT VALID\n"
"_______\n"
"0.00\n"
"00000\n"
"0.0\n"
"0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")