re = /^(?:0?[1-9]\d*(?:\.\d*[0-9]*)?)|(:?^0.[1-9]+0)$/m
str = 'VALID
_______
40000
45
4
45.67
67.8
60.
61.0
1.00
01.00
02.00
03.0
89.50
50.00
0.10
0.1
0.2
0.3
NOT VALID
_______
0.00
00000
0.0
0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end