using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{1,4}\/\d{1,2}\/\d{1,2} \d{1,2}:\d{1,2}:\d{1,2}";
string input = @"Your Last Login was 2013/10/04 13:06:45 ( 0 Days, 0 Hours, 0 Minutes )
您上次登录是 2013/10/04 13:06:45( 0 天, 0 小时 0 分钟 )";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}