const regex = /\d{1,4}\/\d{1,2}\/\d{1,2} \d{1,2}:\d{1,2}:\d{1,2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,4}\\\/\\d{1,2}\\\/\\d{1,2} \\d{1,2}:\\d{1,2}:\\d{1,2}', 'gm')
const str = `Your Last Login was 2013/10/04 13:06:45 ( 0 Days, 0 Hours, 0 Minutes )
您上次登录是 2013/10/04 13:06:45( 0 天, 0 小时 0 分钟 )`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}