use strict;
my $str = 'Your Last Login was 2013/10/04 13:06:45 ( 0 Days, 0 Hours, 0 Minutes )
您上次登录是 2013/10/04 13:06:45( 0 天, 0 小时 0 分钟 )';
my $regex = qr/\d{1,4}\/\d{1,2}\/\d{1,2} \d{1,2}:\d{1,2}:\d{1,2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}