import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Head)(?:(?!Head|Tail).)+(?=Tail)";
final String string = "abc_Head_def_Head_inner_inside_Tail_ghi_Tail_jkl\n"
+ "abc_Head_first_Tail_ghi_Head_second_Tail_opq";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}