re = /(?<=Head)(?:(?!Head|Tail).)+(?=Tail)/m
str = 'abc_Head_def_Head_inner_inside_Tail_ghi_Tail_jkl
abc_Head_first_Tail_ghi_Head_second_Tail_opq'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end