$re = '/(?<=Head)(?:(?!Head|Tail).)+(?=Tail)/m';
$str = 'abc_Head_def_Head_inner_inside_Tail_ghi_Tail_jkl
abc_Head_first_Tail_ghi_Head_second_Tail_opq';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);