import re
regex = re.compile(r"(?<=Head)(?:(?!Head|Tail).)+(?=Tail)", flags=re.MULTILINE)
test_str = ("abc_Head_def_Head_inner_inside_Tail_ghi_Tail_jkl\n"
"abc_Head_first_Tail_ghi_Head_second_Tail_opq")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")