using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(AAD|TMLB|RECHNX|RR4HNX)";
string input = @"LTUS41 KCAR 141558 AAD TMLB Forecast for the National Parks
KHNX 141001 RECHNX Weather Service San Joaquin Valley
LTUS41 KCAR 141558 AAD RR4HNX
LTUS41 KCAR 141558 AAD RECHNX";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}