import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(AAD|TMLB|RECHNX|RR4HNX)";
final String string = "LTUS41 KCAR 141558 AAD TMLB Forecast for the National Parks \n"
+ "KHNX 141001 RECHNX Weather Service San Joaquin Valley\n"
+ "LTUS41 KCAR 141558 AAD RR4HNX\n"
+ "LTUS41 KCAR 141558 AAD RECHNX";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}