package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(AAD|TMLB|RECHNX|RR4HNX)`)
var str = `LTUS41 KCAR 141558 AAD TMLB Forecast for the National Parks
KHNX 141001 RECHNX Weather Service San Joaquin Valley
LTUS41 KCAR 141558 AAD RR4HNX
LTUS41 KCAR 141558 AAD RECHNX`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}