re = /(AAD|TMLB|RECHNX|RR4HNX)/m
str = 'LTUS41 KCAR 141558 AAD TMLB Forecast for the National Parks
KHNX 141001 RECHNX Weather Service San Joaquin Valley
LTUS41 KCAR 141558 AAD RR4HNX
LTUS41 KCAR 141558 AAD RECHNX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end