using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:[^@a-zA-Z0-9]*[a-zA-Z0-9]){2})[a-zA-Z0-9_.-]+@[a-zA-Z0-9.-]+$";
string input = @"__z@gmail.com
invalid(because only one alphanumeric character before @)
z@gmail.com
invalid(because only one alphanumeric character before @)
__zz@gmail.com
Z_Z@gmail.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}