$re = '/^(?=(?:[^@a-zA-Z0-9]*[a-zA-Z0-9]){2})[a-zA-Z0-9_.-]+@[a-zA-Z0-9.-]+$/m';
$str = '__z@gmail.com
invalid(because only one alphanumeric character before @)
z@gmail.com
invalid(because only one alphanumeric character before @)
__zz@gmail.com
Z_Z@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);