import re
regex = re.compile(r"^(?=(?:[^@a-zA-Z0-9]*[a-zA-Z0-9]){2})[a-zA-Z0-9_.-]+@[a-zA-Z0-9.-]+$", flags=re.MULTILINE)
test_str = ("__z@gmail.com\n"
" invalid(because only one alphanumeric character before @)\n"
"z@gmail.com\n"
" invalid(because only one alphanumeric character before @)\n\n"
"__zz@gmail.com\n"
"Z_Z@gmail.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")