# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^|[^\w\n]+)(\w)/\U$1/gm;t' <<< "hello ladies how are you Today
I am fine thank you"