package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|[^\w\n]+)(\w)`)
var str = `hello ladies how are you Today
I am fine thank you`
var substitution = "\U$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}