$re = '/(?:^|[^\w\n]+)(\w)/m';
$str = 'hello ladies how are you Today
I am fine thank you';
$subst = "\U$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;