use strict;
my $str = 'hello ladies how are you Today
I am fine thank you';
my $regex = qr/(?:^|[^\w\n]+)(\w)/mp;
my $subst = '\\U$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";