#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:[/?=_–.-])([a-z]+)(?:[/?=_–.-]))|([a-z]+)"
Local $sString = "-facebook=chat.messenger?" & @CRLF & _
"-facebook=chat.messenger?sdsdsdsds-" & @CRLF & _
"-facebook=chat.messenger?sdsdsdsds-facebook=chat.messenger?sdsdsdsds-" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")