package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:[/?=_–.-])([a-z]+)(?:[/?=_–.-]))|([a-z]+)`)
var str = `-facebook=chat.messenger?
-facebook=chat.messenger?sdsdsdsds-
-facebook=chat.messenger?sdsdsdsds-facebook=chat.messenger?sdsdsdsds-
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}