$re = '/((?:[/?=_–.-])([a-z]+)(?:[/?=_–.-]))|([a-z]+)/m';
$str = '-facebook=chat.messenger?
-facebook=chat.messenger?sdsdsdsds-
-facebook=chat.messenger?sdsdsdsds-facebook=chat.messenger?sdsdsdsds-
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);