using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[/?=_–.-])([a-z]+)(?:[/?=_–.-]))|([a-z]+)";
string input = @"-facebook=chat.messenger?
-facebook=chat.messenger?sdsdsdsds-
-facebook=chat.messenger?sdsdsdsds-facebook=chat.messenger?sdsdsdsds-
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}