#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)^" & @CRLF & _
" (?:(?:\+|00)33|0) # Dialing code" & @CRLF & _
" \s*[1-9] # First number (from 1 to 9)" & @CRLF & _
" (?:[\s.-]*\d{2}){4} # End of the phone number" & @CRLF & _
"$"
Local $sString = "06 01 02 03 04" & @CRLF & _
"+33 6 01 02 03 04" & @CRLF & _
"0033 7 01 02 03 04" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")