re = /^
(?:(?:\+|00)33|0) # Dialing code
\s*[1-9] # First number (from 1 to 9)
(?:[\s.-]*\d{2}){4} # End of the phone number
$/mix
str = '06 01 02 03 04
+33 6 01 02 03 04
0033 7 01 02 03 04
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end