import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ " (?:(?:\\+|00)33|0) # Dialing code\n"
+ " \\s*[1-9] # First number (from 1 to 9)\n"
+ " (?:[\\s.-]*\\d{2}){4} # End of the phone number\n"
+ "$";
final String string = "06 01 02 03 04\n"
+ "+33 6 01 02 03 04\n"
+ "0033 7 01 02 03 04\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}