package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^
(?:(?:\+|00)33|0) # Dialing code
\s*[1-9] # First number (from 1 to 9)
(?:[\s.-]*\d{2}){4} # End of the phone number
$`)
var str = `06 01 02 03 04
+33 6 01 02 03 04
0033 7 01 02 03 04
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}