#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^=+\s?|\s?=+=\s?)"
Local $sString = "====== tOTO ===" & @CRLF & _
" Toto " & @CRLF & _
"====== tOTO ==== " & @CRLF & _
"" & @CRLF & _
"== tOTO =" & @CRLF & _
"asdf" & @CRLF & _
"sDF" & @CRLF & _
"ASDF"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)