using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^=+\s?|\s?=+=\s?)";
string substitution = @"";
string input = @"====== tOTO ===
Toto
====== tOTO ====
== tOTO =
asdf
sDF
ASDF";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}